123Macmini.com
FAQFAQ   SearchSearch   MemberlistMemberlist   GalleryPhoto Gallery   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

mx510 problem

 
Post new topic   Reply to topic    123Macmini.com - Forums Forum Index -> Mac Mini Troubleshooting
View previous topic :: View next topic  
Author Message
thefriscokid
New Member
New Member


Joined: 10 Mar 2005
Posts: 7
Location: UK

PostPosted: Sun Aug 14, 2005 8:04 am    Post subject: mx510 problem Reply with quote

Just bought a new logitech mx510 and was wondering how i get the 2 buttons on the side to work in firefox when browsing. In Windows i can use the 2 buttons to browse backwards and forwrds when using IE, Opera, Firefox etc, but on OS X it doesn't work at all.
_________________
1.42 g4 Mac Mini
256MB SDRAM
80GB HD
Combo Drive

20GB IPOD G4

1GB IPOD SHUFFLE
Back to top
View user's profile Send private message MSN Messenger
devo
Veteran Member
Veteran Member


Joined: 23 Jan 2005
Posts: 5389
Location: Dunwoody, GA

PostPosted: Sun Aug 14, 2005 9:11 am    Post subject: Reply with quote

You may need to download the latest drivers from Logitech. It will set up the Logitech Control Center in your System Preferences. Once you are in the Logitech Control center hit the configure button. You should see all the options for setting up your buttons. I don't have many options with my mouse. Yours might have more options with all the extra buttons.

http://www.logitech.com/index.cfm/downloads/software/US/EN,CRID=1792,contentid=8027,OSID=9
Back to top
View user's profile Send private message
Susurrus
Veteran Member
Veteran Member


Joined: 05 May 2005
Posts: 1303
Location: Providence, Rhode Island

PostPosted: Mon Aug 15, 2005 2:20 pm    Post subject: Reply with quote

I'm using that mouse and you do need the Logitech drives that Devo linked to. The back and forward buttons don't work in the Finder (Suprised? Again, FTFF Apple).
_________________
Computer Engineer
Junior, Brown University
15" NC8430 HP Laptop
1.42Ghz PPC Mac Mini, 1Gb RAM, 1st Gen
40GB G4 iPod
2GB Black iPod Nano
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Toastman
Junior Member
Junior Member


Joined: 30 Aug 2005
Posts: 24

PostPosted: Tue Aug 30, 2005 12:13 pm    Post subject: software? Reply with quote

I had an mx500 (loved it by the way) and I'm wondering, did you install the the software that came with the mouse? If you hadn't, then that's probably the problem..
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    123Macmini.com - Forums Forum Index -> Mac Mini Troubleshooting All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



      

Shop:  Apple Store  |  Refurbished Macs  |  Refurbished iPads  |  MacConnection  |  Mac Mini Vault  |  Other World Computing

MK 1 Studio Mac mini Racks  |  Crucial Mac Memory  |  Top Free Mac Apps  |  Top Paid Mac Apps



123Macmini.com is an independent publication and has not been authorized, sponsored, or approved by Apple Computer, Inc.
All logos and trademarks in this site are property of their respective owners.
Copyright © 2011 123Macmini.com. All Rights Reserved.