123Macmini.com
FAQFAQ   SearchSearch   MemberlistMemberlist   GalleryPhoto Gallery   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

G4 and iMovie

 
Post new topic   Reply to topic    123Macmini.com - Forums Forum Index -> Mac Mini Troubleshooting
View previous topic :: View next topic  
Author Message
aware
New Member
New Member


Joined: 23 Oct 2017
Posts: 3

PostPosted: Mon Oct 23, 2017 8:15 am    Post subject: G4 and iMovie Reply with quote

Hello to all,
I had a Mac mini for ages sitting in the garage.
PowerPC G4 @ 1,42Ghz and 512MB ram
It has iMovie HD installed but I wish to install iMovie 10 that has so nice and sleek themes (I witnessed them on an iPad and was super-impressed) but I can't install any upgrade or any .dmg.
I get errors of "no mountable" and I also try to update the Mac OS (current 10.9.3) but it says it's updated! It's just impossibe; the PC hasn't been updated for more than 10 years!
I just wish that if I update the Mac OS then the iMovie will eventually install?

Am I just dreaming and all these are impossible feats for my old friend?

Thanks in advance
Rolling Eyes
Back to top
View user's profile Send private message
aware
New Member
New Member


Joined: 23 Oct 2017
Posts: 3

PostPosted: Tue Oct 24, 2017 9:08 am    Post subject: Reply with quote

Nobody?
Back to top
View user's profile Send private message
saul
Senior Member
Senior Member


Joined: 22 Mar 2008
Posts: 472
Location: PA

PostPosted: Sun Oct 29, 2017 4:38 pm    Post subject: Reply with quote

From http://mactracker.ca/ it says that 10.5.8 is the maximum OS for your machine. Best installed via DVD-ROM.
iMovie 10 needs 10.9 so you are out of luck. iMovie '09 would be the latest you could run.
Back to top
View user's profile Send private message
aware
New Member
New Member


Joined: 23 Oct 2017
Posts: 3

PostPosted: Thu Nov 02, 2017 9:04 am    Post subject: Reply with quote

Thanks for the answer
I actually have 10.3.9 and the highest compatible version is the imovie HD 6 which is the one I already have and isn't that good as the latest versions.
Problem is that I can't upgrade my iOS. it seems impossible
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    123Macmini.com - Forums Forum Index -> Mac Mini Troubleshooting All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Shop Amazon:  Mac Mini  |  iMac  |   Mac Pro  |  MacBook Air   |  MacBook Pro   |  AirPort Extreme   |  Time Capsule



123Macmini.com is an independent publication and has not been authorized, sponsored, or approved by Apple Computer, Inc.
All logos and trademarks in this site are property of their respective owners.
Copyright © 123Macmini.com. All Rights Reserved.