123Macmini.com
FAQFAQ   SearchSearch   MemberlistMemberlist   GalleryPhoto Gallery   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mac Mail folder issue

 
Post new topic   Reply to topic    123Macmini.com - Forums Forum Index -> General Software
View previous topic :: View next topic  
Author Message
Y-Guy
Senior Member
Senior Member


Joined: 06 Feb 2010
Posts: 484
Location: Tri-Cities, WA

PostPosted: Wed May 02, 2012 4:32 pm    Post subject: Mac Mail folder issue Reply with quote

I could use some thoughts/advice before I head to the Apple Communities. I use two IMAP email accounts one for work and one for home I have my Mini at work, and iMac at home set up and all works well, mostly. I also use my iPhone to access both accounts . When I look at Mail under "Mailboxes" I have collapsed folders for Inbox, Sent, Trash and Junk. Under my work account I also show Trash, Deleted Messages, Drafts and Spam, my home account has the same.

First question is how can I remove the "Deleted Messages" folder since I already have a Trash folder. If I try to remove the folder it deletes but comes back. I assume this is an IMAP folder, but why would I have both Deleted Messages and Trash? Does my iPhone cause this?

I have the Junk folders on my Mac, and both home/work set to not store Junk on the server, so why do I have a Spam folder on my work account and a Junk folder on my home account? Again I assume this is an IMAP issue, or is it?

For the past couple of weeks I've been having a problem with my work account and junk mail. Since I set things up my Junk emails all wound up in my Junk folder locally, not the server under Mailboxes. Now my Junk goes to the Spam folder on my work account. I don’t get much junk at home, but at work that’s another issue. On both my work & home account I have unchecked the box by “store messages on server” and selected Delete junk when one week old. I have tried resetting the junk mail filter as well. However, emails keep going to the Spam folder and not the Junk folder. What am I missing?

I use Ipower for email hosting at work and MacHighway for home, if that helps.

Thanks in advance for any thoughts you may have.
_________________
iMac 24" 2.4 GHz 4GB | Logitech S530 | Z-2300 speakers | NewerTech Guardian MAXimus RAID
MacMini HTPC 2.26 GHz 2GB | Panasonic Plasma TV | Logitech diNovo Edge | Mercury Elite-AL Pro 800
AppleTV1 unhacked | Panasonic LCD
Back to top
View user's profile Send private message
macmanmacman
Veteran Member
Veteran Member


Joined: 25 Oct 2007
Posts: 1849

PostPosted: Tue May 08, 2012 4:32 am    Post subject: Reply with quote

Actually this is a common issue.

I need to know something from you are you using icloud???

the reason i ask for is iCloud is always on in lion and even in snow so everytime you delete the folder icloud just restores it.

i recommend setting up a second e-mail account with google for your business needs but i am warning you now that the iphone only archives the e-mails into a archive folder from which you have to log into mail and delete that folder every time
Back to top
View user's profile Send private message
Y-Guy
Senior Member
Senior Member


Joined: 06 Feb 2010
Posts: 484
Location: Tri-Cities, WA

PostPosted: Tue May 08, 2012 9:57 am    Post subject: Reply with quote

Thanks for the reply. Just very odd that everything worked normally then all of a sudden all my junk goes to the Spam folder now. Very odd.

I don't use iCloud for mail at all, both accounts are IMAP accounts.
_________________
iMac 24" 2.4 GHz 4GB | Logitech S530 | Z-2300 speakers | NewerTech Guardian MAXimus RAID
MacMini HTPC 2.26 GHz 2GB | Panasonic Plasma TV | Logitech diNovo Edge | Mercury Elite-AL Pro 800
AppleTV1 unhacked | Panasonic LCD
Back to top
View user's profile Send private message
Y-Guy
Senior Member
Senior Member


Joined: 06 Feb 2010
Posts: 484
Location: Tri-Cities, WA

PostPosted: Wed May 09, 2012 12:55 pm    Post subject: Reply with quote

I've been beating my head against the keyboard about this for a few days now, spam is at a all time high on my work account, 40+ per day. I turned on the spam block through our web host but that didn't help much, I may look to move to another hose that does a better job of this.

I wanted to first solve my folder problems then deal with spam. What really got me was that everything was working great then it changed. Well I began really playing with the Junk Mail filter options and I've not solved the extra Spam folder at least. Seems my work host iPower creates a folder called Spam for the IMAP accounts. Some how this folder didn't exist, or at least I didn't see it until recently.

Here are the steps I took to get my Junk folder back and to get rid of my Spam folder:
First I stopped using the Advanced feature in Junk mail, I have a feeling this is where my problems started.

Then I changed the settings around to this:
Enable junk mail filtering
Move to the Junk mailbox
Sender of message is in my Address Book
Trust junk mail headers

Don’t check filter junk before rules
I found one guy that had a used a custom rules set that seems to be catching 99% of my junk now. I'll share it below. But the key to make it work was to let the rules run first, the filter the junk.

Then I set the Spam mailbox to be recognized as the Junk folder by going to the View Menu/Mailbox/Use This Mailbox For/Junk.

Now all is right with the world.

Here is the tip from the other user that seems to have helped too:
I don't receive spam because years and years ago I followed a MacWorld article that said to do this: Spammers often harvest email addresses by using images. If you load the image, the spammer gets a valid address.  To avoid this set up a new rule in Mail: Choose Mail>Preferences>Rules. Click on Add Rule button. Type in a name like "Image Spam" in the Description field and choose All from "if (any or all) the conditions are met. Choose Edit Header List from the first condition pop up (way down at bottom of the list). In the dialog box that appears, click on the plus sign button (+) and type in Content Type and click OK. Now choose Content Type and Contains from that same pop up menu and type in Multipart/Related in the blank text field. Click on the plus sign button next to the condition you have just created and use the pop up menu to set up a second condition. Choose Sender Is Not In My Address Book. Click on the plus sign button again and add a third condition choosing Sender Is Not in My Previous Recipients. Now under Perform the Following Actions, set the pop up to Move message to Mailbox: Junk (or Delete). Check your Junk mail periodically in case a legitimate email gets snagged.
_________________
iMac 24" 2.4 GHz 4GB | Logitech S530 | Z-2300 speakers | NewerTech Guardian MAXimus RAID
MacMini HTPC 2.26 GHz 2GB | Panasonic Plasma TV | Logitech diNovo Edge | Mercury Elite-AL Pro 800
AppleTV1 unhacked | Panasonic LCD
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    123Macmini.com - Forums Forum Index -> General Software All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



      

Shop:  Apple Store  |  Refurbished Macs  |  Refurbished iPads  |  MacConnection  |  Mac Mini Vault  |  Other World Computing

MK 1 Studio Mac mini Racks  |  Crucial Mac Memory  |  Top Free Mac Apps  |  Top Paid Mac Apps



123Macmini.com is an independent publication and has not been authorized, sponsored, or approved by Apple Computer, Inc.
All logos and trademarks in this site are property of their respective owners.
Copyright © 2011 123Macmini.com. All Rights Reserved.